ご存知でしたボットのリブレー無料主催 ライブチャット のためにお客様ご自身のウェブサイトまたはモバイルアプリのか?
Bot Libre Forum

problem with my plant aiml script

による bobred 掲載 May 11 2017, 2:43

I have a problem with my chatbots plant aiml script.When i asked it a particular question the first time it answered correctly.Then when i asked it the question

the second time it would not answer correctly.Then it stopped answering correctly that particular question.It won't answer some of question correctly even

though the answers are in the my plant aiml script.What is going on?Here is my script.my plants.aiml.txt


by admin posted May 11 2017, 7:19
I added your plant script to your bot "Blair" and it works.

In general you can import AIML either as a response (which is heuristically matched) or as a script (which is executed programmatically).

If you add it as a response the bot will avoid using the same response twice in a row, so will find another response.

If you add it as a script the bot will always use the same response.

Also, check that you do not have learning enabled, otherwise you will be corrupting your bot's responses.

Also, you had a "?" in your AIML pattern. In general AIML patterns should not contains punctuation, if they do it will be required for the pattern to match. Normally punctuation is ignored when matching a pattern.

Thumbs up: 0, thumbs down: 0, stars: 0.0
Views: 302, today: 0, week: 0, month: 1

by bobred posted May 11 2017, 13:18

Learning is not enabled.Thankyou that worked.I would like to make a guessing game next for blair.I will try to do that.


Thumbs up: 0, thumbs down: 0, stars: 0.0
Views: 279, today: 1, week: 1, month: 3

Id: 16997310
掲載: May 11 2017, 2:43
回答: 2
眺望: 338, 今日の: 1, 週間: 1, 月: 5

フラグとしての攻撃、または違反のサイトのルール